climateprediction.net home page
transient HTTP error + Peer certificate cannot be authenticated
transient HTTP error + Peer certificate cannot be authenticated
log in

Advanced search

Questions and Answers : Unix/Linux : transient HTTP error + Peer certificate cannot be authenticated

Author Message
ToninCPU1
Send message
Joined: 2 Apr 07
Posts: 2
Credit: 117,728
RAC: 1
Message 56491 - Posted: 30 Jun 2017, 18:04:11 UTC

Hi,
I'm running BOINC client (x86_64-pc-linux-gnu 7.2.42)
I have a problem with downloading work units from climateprediction.net project
I firstly saw : Temporarily failed download of wah2_data_8.25_i686-pc-linux-gnu.zip: transient HTTP error

So I added some debug config lines in my BOINC/cc_config.xml

<cc_config> <log_flags> <file_xfer_debug>0</file_xfer_debug> <http_debug>1</http_debug> <http_xfer_debug>0</http_xfer_debug> </log_flags> </cc_config>

Then I saw much more lines, with for instance : HTTP error: Peer certificate cannot be authenticated with given CA certificates
Has anyone a clue of what can be done ?
Thank you for reading.

I have posted the same question, with an extra sample log on https://boinc.berkeley.edu/dev/forum_thread.php?id=11698

Profile astroWX
Volunteer moderator
Send message
Joined: 5 Aug 04
Posts: 1459
Credit: 76,183,576
RAC: 71,704
Message 56492 - Posted: 30 Jun 2017, 19:29:26 UTC - in response to Message 56491.

Machine has boinc version 6.10.56, which doesn't play well with "https". Upgrade to current boinc v.7 and all should be okay -- except that no work is currently available.

Please check that 32-bit libs are installed.
____________
"We have met the enemy and he is us." -- Pogo
Greetings from coastal Washington state, the scenic US Pacific Northwest.

Profile geophi
Volunteer moderator
Send message
Joined: 7 Aug 04
Posts: 1670
Credit: 32,083,245
RAC: 31,083
Message 56493 - Posted: 30 Jun 2017, 22:08:16 UTC - in response to Message 56492.

Machine has boinc version 6.10.56, which doesn't play well with "https". Upgrade to current boinc v.7 and all should be okay -- except that no work is currently available.

Please check that 32-bit libs are installed.

He does have the most current Berkeley release installed so it's not a boinc 6 thing.

But yeah, if you get everything downloaded and have failures during running tasks, let us know and we can help you if you have missing 32bit libraries that cpdn apps need.

I couldn't tell from your last post to the boinc message board if you got the files you need downloaded or not.

ToninCPU1
Send message
Joined: 2 Apr 07
Posts: 2
Credit: 117,728
RAC: 1
Message 56494 - Posted: 1 Jul 2017, 5:53:59 UTC - in response to Message 56493.

Right now, calcultation is running, so I finally got the files thanks an updated ca-bundle.crt
Thank you

Questions and Answers : Unix/Linux : transient HTTP error + Peer certificate cannot be authenticated


Main page · Your account · Message boards


Copyright © 2017 climateprediction.net